Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #25818
    Tobias
    Tobias
    Moderator

    It took longer than I thought (3.5 years!), but the days of Elevate 2 are numbered. There are probably no more apps that can use OpenAndroMaps but are based on a mapsforge version earlier than 0.5. Elevate 2 was still supported for guaranteeing compatibility for those apps, but that will be no longer necessary.
    There are still some problematic cases, but either the problems will be solved by the developers, or the users will have to use the maps without new features. There still might be bug fixes, and it will be possible to download Elevate 2 as long as it makes sense.
    Here’s an overview of apps I tested, those are probably the most popular ones, including support status for mapsforge v4 themes:

    Full support:
    Cachebox
    Cruiser
    BackCountry Navigator
    OruxMaps

    Limited support:
    BikeComputer – you can select mapstyles only, not overlays
    Locus – costumized version necessary

    Buggy support:
    c:geo – mapstyles/overlays are not selectable, all content is shown simultaneously
    RouteConverter – mapstyles/overlays are not selectable, all content is shown simultaneously

    Please help with this list, especially apps that have some kinds of problems or don’t work at all with Elevate 4.

    #25827
    ChristianK
    ChristianK
    Keymaster

    For me thats perfect OK.

    The Overlays and Styles were an essential improvement for Mapsforge Maps.
    .. and invented years ago ..
    Probably same will happen with V3 maps step by step next year.

    No sense to invest resources for long outdated versions

    • This reply was modified 2 months ago by ChristianK ChristianK.
    1 user thanked author for this post.
    #25836
    Emux
    Emux
    Participant

    Progress never stops… :)

    Thanks to community, Mapsforge supports now scaling (also) for PNG in render themes.

    Note: I implemented PNG scaling also in VTM.

    2 users thanked author for this post.
    #25838
    Tobias
    Tobias
    Moderator

    As the speed of adopting new mapsforge support in all apps is quite glacial (with some positive exceptions), it’s always hard for us to keep up to date with the newest developments. So maybe in some more years we’ll have v5 themes and maps ;-)
    But I’m glad that there are always new things happening!

    1 user thanked author for this post.
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.