Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3096
    JohnPercy
    JohnPercy
    Participant

    If a way (highway, aeroway etc) is a closed loop, and overlaps a tile boundary, spurious vertical and/or horizontal lines appear at certain zooms, looking like roads, etc. See the attached images as examples. This occurs with Locus maps and built-in themes as well as OpenAndromaps and other themes at zooms 12, 13 and 14 wherever a highway is mapped as a closed loop.
    This has been discussed previously in the old version of the support pages, and the suggestion of changing BaseZoom levels was investigated and discarded (I think).
    Elsewhere, on the Locus forum, I suggested that
    Where a polygon is closed and has no fill (as with a highway, where we just want to draw the line of the path), is it possible to render it as if it was not closed?
    It was stated in reply that
    we can use parameter force-polygon-line="true" during generation. We use it for contour-lines, that are by definition closed, However we've never used it for highways (are not so often closed as ring), but it could work.
    Assuming that refers to the map creation phase that you do in producing the OpenAndroMaps, would this be an appropriate solution to this real life problem?
    PS. I can’t change the images I have uploaded, but the first one shows the correct road layout near Wolferton, the second one shows spurious N-S and E-W roads on an airfield, and the third and fourth images (which are the same) show the spurious roads in the same location as the first image.

    #3105
    Emux
    Emux
    Participant

    I remember Maki has posted a related issue at Mapsforge mailing list:
    https://groups.google.com/d/msg/mapsforge-dev/4GITa-POt0Y/fZumr8vDawIJ

    And then we had discussed it more here:
    https://groups.google.com/forum/#!topic/mapsforge-dev/pGTOFv1RPpE

    A fix has been implemented in latest MapWriter, so you could try the specific regions with it.

    Emux
    CruiserAtlas

    #3106
    ChristianK
    ChristianK
    Keymaster

    A fix has been implemented in latest MapWriter, so you could try the specific regions with it.

    Last night I rendered GreatBritain with the latest SnapshotVersion of the Mapwriter and the results are the same.
    Both on Locus and Orux6.01.

    I will give the force-polygon a try – howeverthis option isnt made for highways an Im afraid of side effects.
    So I suppose we have to life with this issue till the mapwriter is modified.

    Best regards,
    Christian

    #3622
    JohnPercy
    JohnPercy
    Participant

    The latest maps from the Locus store are rendered with a larger tile size (see http://forum.locusmap.eu/index.php?topic=2720.msg33873#msg33873 ) which appears to go a long way (but not all the way!) to resolving this issue. Is this worth adopting for OpenAndroMaps?

    #3627
    Emux
    Emux
    Participant

    The rendering is performed live on the client, the map files have nothing to do with it. So the tile size is eventually client oriented.

    i.e. official Mapsforge now uses variable tile size, based on device’s dpi.
    (That’s how Cruiser works)

    AFAIK Locus uses a fixed tile size 512.
    I’m not aware what rendering decision Orux has made regarding the tile size.

    Emux
    CruiserAtlas

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.