Ansicht von 9 Beiträgen - 31 bis 39 (von insgesamt 39)
  • Autor
    Beiträge
  • #25368
    ChristianK
    ChristianK
    Keymaster

    Bei den Boundarys ist mir ein kleiner Bug aufgefaallen:
    Wenn diese zB in Flüssen verlaufen werden die Grenzen nicht dargestellt weil diese blau überrendered werden.
    Ich habe nun im preprozessing die boundary/administrative/admin_level* auf layer=1 gesetzt, damit sollte dieses Problem erledigt sein.

    #25372
    Tobias
    Tobias
    Moderator

    Bei den Boundarys ist mir ein kleiner Bug aufgefaallen:

    Wenn diese zB in Flüssen verlaufen werden die Grenzen nicht dargestellt weil diese blau überrendered werden.

    Ich habe nun im preprozessing die boundary/administrative/admin_level* auf layer=1 gesetzt, damit sollte dieses Problem erledigt sein.

    Das sollte nur passieren, wenn ein falscher layer=1 beim Gewässer gesetzt ist. Das ist ein „beliebter“ Mapping-Fehler (Wasser fließt AUF dem Untergrund, also layer=1!?). Wenn es korrekt ist, gibt es kein Problem mit den Grenzen. Jedoch gibt es ein Problem, wenn jetzt alle Grenzen layer=1 sind, denn dann werden Wege unter Grenzen und somit nicht mehr sichtbar dargestellt, wenn sie an der Grenze verlaufen. Deshalb wäre ich dafür, das nicht umzusetzen (gerne z.B. an Graten, an denen Grenzen verlaufen).

    Viele Grüße,
    Tobias

    #25375
    ChristianK
    ChristianK
    Keymaster

    Hallo @tobias,

    Du hast leider recht, ich probiere das Ganze eben bei Uruguay aus – Mapsforge kann scheinbar doch keine Boundary-Relationen auflösen, was unschön ist. Ich muss hier etwas eigenes stricken – so wie gehabt bei icn,iwn.

    Welche key/values brauchts Du – es wird ev. eng mit den 16tags/way

    LG, Christian

    #25386
    ChristianK
    ChristianK
    Keymaster

    Das wird etwas dauern, OSMFilter hat einen Bug, der kann scheinbar numerische Values unter WIN7/64 nicht sauber filtern, da kommt nur Müll raus. zB admin_level<=4 wirft auch admin_level=9 raus, in welchen Syntax Kombinationen/Variationen auch immer.

    #25388
    Tobias
    Tobias
    Moderator

    Den bug hatte ich schon mal gemeldet:
    https://github.com/mapsforge/mapsforge/issues/602

    Probier da doch auch das tag-transform von type=boundary zu type=multipolygon – dann sollten die boundaries auftauchen.

    Viele Grüße,
    Tobias

    #25392
    ChristianK
    ChristianK
    Keymaster

    Den Trick hatte ich völlig vergessen, funktioniert prima -DANKE

    Screenshot-2018-08-31-07.45

    1 Teilnehmer(n) gefällt dieser Beitrag
    #26463

    gscholz
    Teilnehmer

    Hallo Christian,
    gibt es schon einen Termin für eine Aktualisierung der Südamerika-Karten? Der Bestand ist bald vier Monate alt.
    Gruß
    Guido

    #26465
    ChristianK
    ChristianK
    Keymaster

    Ich wollte Anfang 2019 alle Karten updaten.
    Wenn Du die Südamerika-Karten vorher benötigst schubse ich die Scripts an.

    LG, Christian

    #26482

    gscholz
    Teilnehmer

    Hallo Christian,
    danke für die Rückmeldung. Akut habe ich keinen Bedarf, Ende des Jahres reicht mir.
    Gruß
    Guido

Ansicht von 9 Beiträgen - 31 bis 39 (von insgesamt 39)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.