Betrachte 2 Beiträge - 1 bis 2 (von insgesamt 2)
  • Autor
  • #53678

    I have a doubt, I’m starting to edit my own Theme. I have downloaded from Mapphorge an XML that is called default.
    Well, in addition to this XML you need to download two folders, symbols and pattern, so far as normal.
    I have begun to edit it, I have added the code to be able to see the contour lines, all perfect (I am a rookie but thanks to your help I am getting very good results XD).
    My problem arises when I missed the symbols folder … I don’t know why but I eliminated it.
    Then I raised my XML modified to my cyclocomputer (it has no Internet connection) to see if the details are well appreciated.
    And my surprise is that although I have not added the symbols folder, because these elements are also shown how can this be?
    Normally with other Themes, if I want you not to see, for example a lighthouse, I eliminate it from the symbols folder and no longer appears (it is faster than editing the XDXD code).
    But this does not work with this Theme, I have tried several devices and not only with the Symbols folder, but I have also tried the Patterns folder and it happens exactly the same.
    This is an example of the route that shows the XML with the option to show the symbol of a lighthouse

    <rule e = „node“ k = „man_made“ v = „lighthouse“ zoom-min = „14“>>
    <symbol id = „lighthouse“ src = „file: symbols/transport/lighthouse.svg“/>
    <rule e = „any“ k = „*“ v = „*“ zoom-min = „17“>
    Stroke = „#Ffffff“ Stroke-Width = „2.0“ Symbol-ID = „Lighthouse“ />

    If the Symbols directory does not exist … the lighthouse should not be shown, is it correct?
    This seems witchcraft … or I am not understanding something.


    Theme resources can come from various internal / external sources: files, jars, Android assets, etc.
    Mapsforge and VTM include a predefined collection of symbols and patterns, used in their themes.

    If a theme resource is missing, the library tries to find it in this collection, before failing completely.

    Emux – Mapsforge / VTM developer

    1 Teilnehmer(n) gefällt dieser Beitrag
Betrachte 2 Beiträge - 1 bis 2 (von insgesamt 2)
  • Sie müssen angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.