Verschlagwortet: ,

Betrachte 15 Beiträge - 151 bis 165 (von insgesamt 228)
  • Autor
    Beiträge
  • #34658
    R5O.nlR5O.nl
    Teilnehmer

    Thanks for all, great steps. I have been testing in latest Locus Pro, using the latest DB (post #34639) and observation on language for POI that are not ’named‘ in OSM:
    This chapel is now called ‚Kirche‘ in Locus:
    https://www.openstreetmap.org/?mlat=51.51453&mlon=4.97734#map=18/51.51453/4.97734
    This drinking water thing is called ‚Trinkwasser‘ in Locus:
    https://www.openstreetmap.org/?mlat=51.55462&mlon=5.08454#map=19/51.55462/5.08454
    Suggestion: by default use the English names for POIs?
    I reckon the difference with a chapel like following one is that it has a ’name‘:
    https://www.openstreetmap.org/?mlat=51.60991&mlon=5.07388#map=19/51.60991/5.07388

    1 Teilnehmer(n) gefällt dieser Beitrag
    VIM
    #34787
    ChristianKChristianK
    Verwalter

    Sorry for beeing a little bit „non responsive“ here in this thread ;-)
    The reason is that I had to learn SQLITE::Perl handling….

    So i finally managed to get the Link to OpenStreetMap for every POI working
    (for next update of maps…)

    ######

    Ich bitte um Verzeihung das ich mich in diesem Thread etwas rar mache – ich war die letzten tage damit beschäftigt den Umgang mit PERL:.SQLITE zu verinnerlichen.
    Nun bin ich so weit das der Link von den einzelnen POIs zur OpenStreetMap Datenbank/Website funktioniert
    (ab dem nächsten Update der Karten)

    Siehe dieses kleine Video / Here a short ScreenCast:

    9 users thanked author for this post.
    #34810
    ThomasMeister
    Teilnehmer

    Perfekt. Lass Dir Deinen Cappuchino schmecken ;)

    1 Teilnehmer(n) gefällt dieser Beitrag
    #34873
    JohnPercyJohnPercy
    Teilnehmer

    Christian wrote:
    Multilingual: I have no idea how this is done in Locus ??

    I note that where the poi has no name, the point table in the LoMap poi database has a blank for the name entry, while this OAM database has a German translation of the POI category, such as Briefkasten. I’ve not explored further but what happens if the name is left blank, as it is in the original data?

    #34882
    JohnPercyJohnPercy
    Teilnehmer

    Further comment: Personally I’m probably not looking for true multilingual functionality although that might be attractive in some circumstances (particularly where multiple scripts are in use). It’s the substitution of German category names for POIs with no name that irks me.

    2 users thanked author for this post.
    #34890
    ChristianKChristianK
    Verwalter

    It’s the substitution of German category names for POIs with no name that irks me.

    Hi John,

    got it !!
    Will be resolved…

    Thanks and best regards
    Chriistian

    #34951
    JohnPercyJohnPercy
    Teilnehmer

    Thanks for the updates!
    I’ve found that for best functionality in Locus, the OAM maps and data should be placed in a subdirectory of mapsVector and not directly in mapsVector. Otherwise, the OAM database blocks the Locus address popup.

    #34953
    R5O.nlR5O.nl
    Teilnehmer

    Pls be informed that I reported an issue on showing POI (that disappeared) in Locus and that was fixed in recent 3.45.0:
    https://help.locusmap.eu/topic/icons-disappearing

    1 Teilnehmer(n) gefällt dieser Beitrag
    #35240
    Eichhorn
    Teilnehmer

    Das jetzt die POI Daten auch in Locus angezeigt werden ist erst einmal super. Ich habe allerdings mit dem aktuellen Karten und POI Update Probleme. Die POI’s werden nicht mehr angezeigt, man kann in den POI’s nicht einmal das Bundesland auswählen.
    Kartenupdate vom 22.3. funktioniert einwandfrei, das Update vom 24.4. geht nicht mehr.

    #35254
    Eichhorn
    Teilnehmer

    EDIT: An der aktuellen Locus Version kann es aber scheinbar nicht liegen, da die älteren POI´s angezeigt werden. Ich habe z.B. Karten vom 22.3. von Sachsen, Sachsen-Anhalt, Thüringen und Bayern. Bei diesen alles wunderbar. Jetzt habe ich mir die aktuelle Karte von Brandenburg zusätzlich geladen (aktuell 24.4.) bei dieser geht es nicht. Die passenden *.poi, bzw. *.db Dateien sind für alle Regionen vorhanden.

    Gruß Eichhorn

    #35260
    ChristianKChristianK
    Verwalter

    Jetzt habe ich mir die aktuelle Karte von Brandenburg zusätzlich geladen (aktuell 24.4.) bei dieser geht es nicht. Die passenden *.poi, bzw. *.db Dateien sind für alle Regionen vorhanden.

    In den neuen Karten ist die Locus poi.db nicht mehr enthalten.
    Warum: Die Adressuche per langen klick auf die Karte funktioniert mit den OAM-Locus.pois nicht, wird sie nie – darum habe ich die .DB aus dem Kartenzip entfernt.
    Bitte lade diese extra über die Schnellinstallation herunter, am besten VOR der eigentlichen Karte.
    Brandenburg + Pois funktionier wunderbar, gerade getestet.

    Allerdings: Bei NewZealand habe ich auch Probleme – es sei denn ich benenne Karte+Pois in
    New_Zealand um (weis der Geier warum)…

    LG Christian

    #35268
    Eichhorn
    Teilnehmer

    Hallo Christian,
    genau wie Du es beschrieben hast, habe ich die Karten und POI´s installiert. Die Dateien sind im richtigen Ordner vorhanden, die Karte wird auch angezeigt, die POI´s aber nicht. Das mit Brandenburg war auch nur ein Beispiel, das Problem habe ich leider bei allen neuen Karten. Gibt es keine Möglichkeit die POI´s „händisch“ zu registrieren? Als Anhang mal die entsprechenden Screenshoots zur Ansicht.

    #35273
    ChristianKChristianK
    Verwalter

    Nicht schön…..

    Ich hatte so einen Lock auch mal.
    Ev. Lösung: Auf Online Karte schalten, alle Karten+Pois löschen.
    Kartenmanager > refresh
    Brandenburg pois + map neu installieren.

    Es ist ‚halt so das sowohl Locus Pois an sich als auch die Konvertierung der Mapsforge Pois nach Locus Beta ist.
    Schade, denn das was (zB) ich brauche = suche nach drinking_water funktioniert super.

    Nur wenn das solche Probleme verursacht wird das wohl BETA bleiben oder sogar wieder verschwinden.

    #35275
    Eichhorn
    Teilnehmer

    Hallo Christian,
    ich hatte jetzt alle Offlinekarten über Locus gelöscht, die ganzen POIs waren im Ordner noch vorhanden. Ich habe danach den Ordner mapsVector komplett geleert. Jetzt Locus gestartet und auf eine Onlinekarte umgeschaltet. Jetzt Themes neu installiert, danach alle benötigten Karten POIs zuerst. Brandenburg POIs fehlen wieder. Jetzt als Test Berlin zusätzlich, diese POIs sind da. Weiß der Geier was da los ist.

    #35277
    mbe57
    Teilnehmer

    Ich denke Menion ist da gefordert einmal aufzuräumen. Aber da sie ja LM4 Im Sommer releasen wollen, wird das noch ein wenig dauern.
    Bei vielen Leuten klappt das mit den OAM-POIs – sie wieder einzustellen wäre genau das falsche Signal, meine ich.

Betrachte 15 Beiträge - 151 bis 165 (von insgesamt 228)
  • Sie müssen angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.