Betrachte 4 Beiträge - 1 bis 4 (von insgesamt 4)
  • Autor
    Beiträge
  • #39522

    nero
    Teilnehmer

    Hi,
    aus Kompatibilitätsgründen verwende ich hier noch Locus 3.37.2 (Android 4), jetzt mit den aktuellsten Karten von hier und einem älteren Elevate 4.1.7. Elevate 4.4.X lässt sich in dieser Locus Version nicht installieren, weder per Schnellinstallation noch manuell. Es wird in der Themenauswahl nicht angezeigt und ist vermutlich inkompatibel mit dieser Locus Version. Auch diese pseudo legacy Version 4.3.3.2 funktioniert leider nicht. Ich benötige eine etwas aktueller Elevate Version die mit Locus 3.37.2 noch kompatibel ist.
    Danke & Grüße

    #39530
    Tobias
    Tobias
    Moderator

    Elevate LE 4.3.3.2 ist keine pseudo Legacy Version, sondern sollte wunderbar mit deinem Locus 3.37.2 und V3-Karten funktionieren.

    Normales Elevate (also nicht LE) wird für Locus erst ab 3.38 empfohlen, ebenso V4-Karten. Erst seit 3.38 hat Locus eine vernünftige Unterstützung für V4-Karten und moderne Themes, alles andere ist eher schlecht. Deshalb macht es auch keinen Sinn, auch noch eine Version für V4-Karten und veraltetes Locus anzubieten.

    Falls du die Legacy Version für OruxMaps meinst, dann ist die nicht für Locus 3.37.2 gedacht, Locus ist besonders vor 3.38 sehr eigen was die Verzeichnisstruktur von Themes betrifft. Da darf nur eine XML-Datei pro Unterverzeichnis sein, deshalb wenn du das probieren willst, entpacke sie in ein Unterverzeichnis und lösche entweder Elevate.xml oder Elements.xml:

    Also entweder mit V4-Karten, ggf. anpassen von Themes per Hand und schlechter, langsamer Darstellung leben oder veraltete V3-Karten nehmen (wobei die noch deutlicher neuer als dein Smartphone sein dürften :-))

    Developer of Elevate mapstyle

    #39550

    nero
    Teilnehmer

    Vielen Dank für die ausführliche Erklärung!
    Es gab da meinerseits Missverständnisse… Auf der Elevate Downloadseite bekommt man den Eindruck dass es sich bei dem Elevate LE um eine sehr veraltete Version handelt. Es ist nirgendwo (ausser in der XML Datei) angegeben welche Version das ist. In der alten Version 4.1.7 gibt es auch schon ein Elevate „LE“ welches vermutlich das Elevate 2 ist. Auch habe ich nicht intuitiv herausgefunden dass man über das „+“ bei den Kartendownloads auch noch recht aktuelle V3 Karten herunterladen kann. Und mir war auch unklar ob ich in Locus 3.37.2 die V4 Karten verwenden sollte oder nicht, da die neusten V4 Karten von Locus geladen und angezeigt werden.
    Elevate LE in Kombination mit den noch recht aktuellen V3 Karten funktioniert wunderbar!
    Sonnige Grüße

    1 Teilnehmer(n) gefällt dieser Beitrag
    #39561
    Tobias
    Tobias
    Moderator

    Danke für den Hinweis, werde die Download-Seite entsprechend anpassen. Elevate LE war nicht Elevate 2, sondern die Anpassung von Elevate 3/4 für die V3 Karten unter Locus. Wie gesagt war Locus und Mapsforge Karten schon immer etwas speziell :-)
    Zu dem Thema gibt es hier auch Beiträge:
    https://www.openandromaps.org/elevate-einstellung-der-locus-spezialversionen
    https://www.openandromaps.org/letztes-update-der-alten-v3-karten

    Developer of Elevate mapstyle

    1 Teilnehmer(n) gefällt dieser Beitrag
Betrachte 4 Beiträge - 1 bis 4 (von insgesamt 4)

Sie müssen angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.