Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #55274
    mr.obw
    Participant

    Hallo Christian,
    eventuell hat sich ein Fehler in die Dezember-Karten eingeschlichen oder du hast bei den oberirdischen Rohrleitungen etwas verändert, das sich mit Elevate/Elements beißt:

    z.B. wird diese Rohrleitung https://www.openstreetmap.org/way/266656254#map=17/47.86209/11.86404 in der Dezember-Karte (Ostalpen, Bayern) mit Elevate/Elements nicht angezeigt, in einer älteren Karte (ich glaube es ist die November-Karte) aber schon. Andere Themes (Tapiola und Tiramisu) zeigen sie auch in der Dezember Karte an.

    #55275
    mr.obw
    Participant

    Entschuldige bitte, habe vergessen zu schreiben, dass ich dieses Verhalten bei Oruxmaps in den Versionen 10.5.0 GP und 10.5.3 beta 3 und 4 festgestellt habe. Über andere Programmversionen oder Apps kann ich nichts sagen.

    #55276
    Tapio
    Participant

    AFAICS the underground pipeline at 47.86824,11.866912 is not included in OAM V5 Germany december – but its caption is displayed. I’m using LM4. This is the code:

    			<rule e="way" k="location" v="underground">
    				<line stroke="#BB5E8BAD" stroke-width="0.8" stroke-linecap="butt" />
    				<line stroke="#BBb5d6f1" stroke-width="0.6" scale="all" stroke-dasharray="2,0.4" stroke-linecap="butt" />
    				<line stroke="#BBffffff" stroke-width="0.2" stroke-linecap="butt" />
    				<pathText k="name" font-style="bold" font-size="10" fill="#BB8C96AA" stroke="#BBFFFFFF" stroke-width="1.8" repeat="true" repeat-gap="300" repeat-start="30" />
    			</rule> 

    Tapiola MFV4+ theme for OAM Maps:
    Releases - DL latest zip - Latest xml

    • This reply was modified 2 months, 2 weeks ago by Tapio.
    #55284
    mr.obw
    Participant

    Here three screenshots from Oruxmaps 10.5.3 beta 3 with December’s AlpsEast map and Elevate 5.3.1 / Tapiola 1.4.0 / Tiramisu . So the pipeline does exist in the map …
    The overground pipeline is displayed correctly in November’s map with all themes mentioned above.
    Same problem in Oruxmaps 10.5.0 GP.

    #55292
    Tapio
    Participant

    Yes that’s right. I was only referring to the underground part of the pipeline.

    Tapiola MFV4+ theme for OAM Maps:
    Releases - DL latest zip - Latest xml

    • This reply was modified 2 months, 2 weeks ago by Tapio.
    #55294
    mr.obw
    Participant

    The underground part of the pipeline is also in the December map. It is displayed correctly with Elevate and Tiramisu but not visible in Tapiola. The two screenshots show the point where the underground becomes an overground pipeline. The one without the overground pipeline is the December map.
    I took a quick look at other underground pipelines. Tapiola seems to show pipelines with location=underground as long as there is no negative layer value.

    • This reply was modified 2 months, 2 weeks ago by mr.obw.
    #55298
    Tapio
    Participant

    Thx, will investigate. Did you use my latest xml? They aren’t in latest zip release.

    Tapiola MFV4+ theme for OAM Maps:
    Releases - DL latest zip - Latest xml

    • This reply was modified 2 months, 2 weeks ago by Tapio.
    #55301
    Avatar photoTobias
    Keymaster

    eventuell hat sich ein Fehler in die Dezember-Karten eingeschlichen oder du hast bei den oberirdischen Rohrleitungen etwas verändert, das sich mit Elevate/Elements beißt:

    Danke, das liegt an dieser Änderung im tag-mapping:
    https://www.openandromaps.org/oam-forums/topic/man_madepipeline
    Wird mit der nächsten Elevate-Version geändert. Bisher wurden pipelines, die kein “location”-tag enthalten, als oberirdisch dargestellt (im Gegensatz zu location=underground). Jetzt haben diese location=overground und dafür gab es noch keine Darstellung.

    Developer of Elevate mapstyle

    2 users thanked author for this post.
    #55303
    mr.obw
    Participant

    Vielen Dank Tobias!
    Obwohl ich einigermaßen fleißig mitlese, habe ich den Beitrag übersehen.

    #55312
    mr.obw
    Participant

    Hello Tapio,
    the problem with the undeground part of the pipeline ( https://www.openstreetmap.org/way/172413378) is probably the tag layer=-1. The pipeline is rendered underneath landuse. For the screenshot I have removed the patterns and the colouring of forest and meadow in your last xml.
    The underground pipeline https://www.openstreetmap.org/way/624175099 is rendered correctly in Tapiola as it does not have a negative layer tag.

    1 user thanked author for this post.
    #55330
    Tapio
    Participant

    Hello Tapio,
    the problem with the undeground part of the pipeline ( https://www.openstreetmap.org/way/172413378) is probably the tag layer=-1. The pipeline is rendered underneath landuse. For the screenshot I have removed the patterns and the colouring of forest and meadow in your last xml.
    The underground pipeline https://www.openstreetmap.org/way/624175099 is rendered correctly in Tapiola as it does not have a negative layer tag.

    I guess I would have to introduce transparency again, but that’s not fun. And brings back unwanted rendering of patterns.

    Tapiola MFV4+ theme for OAM Maps:
    Releases - DL latest zip - Latest xml

    #55724
    Avatar photoTobias
    Keymaster

    eventuell hat sich ein Fehler in die Dezember-Karten eingeschlichen oder du hast bei den oberirdischen Rohrleitungen etwas verändert, das sich mit Elevate/Elements beißt:

    Danke, das liegt an dieser Änderung im tag-mapping:
    https://www.openandromaps.org/oam-forums/topic/man_madepipeline
    Wird mit der nächsten Elevate-Version geändert. Bisher wurden pipelines, die kein “location”-tag enthalten, als oberirdisch dargestellt (im Gegensatz zu location=underground). Jetzt haben diese location=overground und dafür gab es noch keine Darstellung.

    Ist jetzt mit Elevate 5.4 geändert.

    Developer of Elevate mapstyle

    3 users thanked author for this post.
Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.