Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #55497
    agocurti
    Participant

    Hi folks, I’m using Oruxmaps 8.5 and I just updated Elevate style from 5.2 to 5.3.1. Now I can’t see any map on Oruxmaps… May be for the current Elevate release I MUST update the maps?

    #55498
    mbe57
    Moderator

    How old are your maps then?
    In any case it is good practice to keep themes and maps a bit in sync.
    I’d try a new small map first (e.g. Madeira), so you know in a minute what’s going on.

    #55499
    agocurti
    Participant

    I think my maps are V4 (2022/23, then not too old)… They are working fine with Elevate 5.2, why the Elevate 5.3 don’t are working with V5 maps? May be my Oruxmaps release is too old?

    • This reply was modified 1 month, 3 weeks ago by agocurti.
    #55502
    Matthias
    Participant

    I suggest you update to “OruxMaps 10.5.0 GP” first, followed by a Map and Theme update.

    1 user thanked author for this post.
    #55503
    Avatar photoTobias
    Keymaster

    You can always use old maps with newer apps/themes, but you might miss something, as for 100% feature compatibility maps and themes should be from the same date.

    But with newer themes/maps also newer mapsforge versions in the apps might be needed; checking the requirements helps. In the Elevate changelog:
    “5.3 16/09/23
    – now at least mapsforge 0.19 is required”
    (Also on the download page).

    Which mapsforge version is supported should be in the changelog of the app, but not every app developer publishes this.

    A legacy Elevate 5.2 is also available for older apps.

    Developer of Elevate mapstyle

    1 user thanked author for this post.
    #55508
    agocurti
    Participant

    Hello Tobias,
    thanks for your answer. I will try with a newer OM release. Thanks for your work!

    1 user thanked author for this post.
    #55511
    kartnisse
    Participant

    I have exactly the same problem with Elevate update. Elevate 5.2 works fine on the map I downloaded from openandromaps some days ago. Elevate 5.3.1 shows nothing (no map at all, just light blue-grey). I have Android 14 and Orux 9.0.1 GP.

    #55512
    agocurti
    Participant

    Hi kartnisse, yes this is behavior that I seen. Try to clear the cache in OM (from Settings=>Maps), it seems this is works….

    #55513
    Avatar photoTobias
    Keymaster

    I have exactly the same problem with Elevate update. Elevate 5.2 works fine on the map I downloaded from openandromaps some days ago. Elevate 5.3.1 shows nothing (no map at all, just light blue-grey). I have Android 14 and Orux 9.0.1 GP.

    As written above: https://www.openandromaps.org/oam-forums/topic/oruxmaps-elevate-style-and-maps#post-55503
    You need a current OruxMaps version for Elevate 5.3 and higher, I think at least 10.1 or 10.5 (most of the time it’s not in the OruxMaps changelog which mapsforge version is used).

    Developer of Elevate mapstyle

    #55514
    kartnisse
    Participant

    OK. You are (of course) right. Orux 10.5.0 and Elevate5.3.1 are fine on a fresh map.Thanks

    1 user thanked author for this post.
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.