Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #10051
    JohnPercy
    JohnPercy
    Participant

    Well, poorly documented anyway.
    Although the tag-mapping page (https://www.openandromaps.org/en/map-basics-2/tag-mapping) says:

    For maps from 17th of February 2014:
    – added cycleway=lane
    – added cycleway=track

    I think the actual mapping is

    For maps from 17th of February 2014:
    – added cycleway=lane
    – added cycleway=cw_track

    Documentation of the correct mapping is buried in tagmapping-min and tagmapping-urban, on the same page.

    The available Elevate map styles incorrectly make use of cycleway=track instead of cycleway=cw_track

    #10057
    Tobias
    Tobias
    Moderator

    Hi John,
    not undocumented – just have a look at the tag-mapping code at the bottom of the page.
    @Christian – maybe it’s time to move it to the top as the changelog got so long?

    At first it was cycleway=track, but last year I asked Chrisitian to change it because of common value bug, but forgot to implement it in Elevate after the change. That wasn’t documented.

    Thanks for the hint anyway, I’ll change that now.
    Best regards,
    Tobias

    Developer of Elevate mapstyle

    #10066
    ChristianK
    ChristianK
    Keymaster

    Hi John,

    Thanks for reporting this issue – you are right, both of us forgot to finish an agreed change in mapping.
    Nobody’s perfect

    I updated the Changelog.

    ;-)

    Best regards
    Christian

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.