Tagged: ,

Viewing 15 posts - 166 through 180 (of 262 total)
  • Author
    Posts
  • #35291
    ChristianK
    ChristianK
    Keymaster

    Ich hatte die gleichen Probleme mit der NewZealand Karte+Pois.
    Nun gerade wieder neu installiert über die Schnellinstallation
    = funktioniert, keine Ahnung warum das letzte Mal nicht.

    Aber was produktives:
    Michael hat mich wieder daran erinnert das weder in den Mapsforge noch in den Locus PoiDBs jene Pois enthalten sind die an Relationen gebunden sind. Das wird nun bereinigt, die RelationsPOIs werden in Punkte umgewandelt und in die PoiDB geschrieben.
    In Locus fehlt bei diesen Pois dann der Link zur OSM-Datenbank.

    AB: Dem Juni-Update….

    ####
    I had the same problems with the NewZealand Map+Pois.
    (PoiDb doesnt appear in list)
    Now just reinstalled again using the Quick Install
    = works, don’t know why last time didn’t.

    But something productive:
    Michael reminded me again that neither the Mapsforge nor the Locus PoiDBs contain the pois that are bound to relations. This will be cleaned up now, the RelationsPOIs will be converted to Nodes and written to the PoiDB.
    In Locus the link to the OSM database is missing for these Pois.

    From: June update…

    2 users thanked author for this post.
    #35302

    mbe57
    Participant

    Du bist ja blitzartig unterwegs, Christian, super !!

    #35304

    ThomasMeister
    Participant

    Wie lade ich denn die DB.-Datei auf dem PC runter? Im Zip ist sie ja nicht mehr drin. Hab mir ein Skript geschrieben, mit dem ich die bearbeite. Daher brauche ich sie auf dem PC…

    #35308
    ChristianK
    ChristianK
    Keymaster

    https://ftp5.gwdg.de/pub/misc/openstreetmap/openandromaps/pois/

    Ohne das großzügige File-Hosting für OSM Projekte der https://www.gwdg.de/de wäre vieles nicht denkbar – kein Privater kann sich die nötige Bandbreite auch nur im Ansatz leisten ohne Haus und Hof zu verlieren.
    Sollte auch mal erwähnt werden :-)

    7 users thanked author for this post.
    #35322

    Eichhorn
    Participant

    Habe mal noch etwas mit den POIs rum gespielt. Österreich funktioniert auch wunderbar. Auf meinem Tablett habe ich die Brandenburg POIs zum Laufen bekommen, aber erst nach der 3. oder 4. Schnellinstallation. Auf dem Smartphone wird Brandenburg konsequent verweigert????
    Dann lassen wir die Brandenburger eben Brandenburger sein. :-)

    #35324
    R5O.nl
    R5O.nl
    Participant

    Habe mal noch etwas mit den POIs rum gespielt. Österreich funktioniert auch wunderbar. Auf meinem Tablett habe ich die Brandenburg POIs zum Laufen bekommen, aber erst nach der 3. oder 4. Schnellinstallation. Auf dem Smartphone wird Brandenburg konsequent verweigert????
    Dann lassen wir die Brandenburger eben Brandenburger sein. :-)

    Again, pls make sure you have the latest Locus installed: https://help.locusmap.eu/topic/icons-disappearing

    #35326

    Eichhorn
    Participant

    Ich nutze Version 3.45.1

    #35337

    Mapper
    Participant

    Goodmorning to all of you,
    I recently discovered your great workt to get POI (LoPoints) working together with openandromaps in Locus Map Pro. Untill now I created my own POI files by extracting the important ones from Garmin OpenTopo maps (with GPSMapEdit) and importing them as gpx files in Locus.
    Since your db files look awesome I tried it yesterday with the map of the Netherlands in Locus 3.45.1 but I couldn’t get it working.
    First I installed the map and the db file manually by placing both files (Netherlands_oam.osm.map + Netherlands_oam.osm.db) in the Locus/mapsVector folder on my SD-card. I can use the map but LoPoints doesn’t show anything. I removed both files, restarted my, phone and tried the automatic anstallation from the browser on my Samsung A8 but the result was the same; both files are stored in exactly the same place and LoPoints don’t work.
    I understand that POI for Locus is still in Beta stage and I must be patient but maybe I am doing something wrong here?

    #35339
    JohnPercy
    JohnPercy
    Participant

    [EN] @mapper
    In my experience the db file has not always copied correctly. Does its size on your device agree with the size in the download list? Which LoPoints function is not working? You can access LoPoints in several ways.

    @Christian
    Please note that Menion writes in the LoMaps forum:
    “If DB contains pois or addresses is defined inside this database by versiondbaddress and versiondbpoi keys in MetaData table”
    Could you please try changing the value of versiondbaddress to 0 in that table for better compatibility with Locus.

    [DE] @ Mapper
    Nach meiner Erfahrung wurde die Datenbankdatei nicht immer korrekt kopiert. Stimmt die Größe Ihres Geräts mit der Größe in der Downloadliste überein? Welche LoPoints-Funktion funktioniert nicht? Sie können auf verschiedene Arten auf LoPoints zugreifen.

    @Christian
    Bitte beachten Sie, dass Menion im LoMaps-Forum schreibt:
    “Wenn die Datenbank Pois oder Adressen enthält, wird diese Datenbank in dieser Datenbank durch die Schlüssel versiondbaddress und versiondbpoi in der MetaData-Tabelle definiert.”
    Könnten Sie bitte versuchen, den Wert von versiondbaddress in dieser Tabelle auf 0 zu ändern, um eine bessere Kompatibilität mit Locus zu erreichen.

    1 user thanked author for this post.
    #35343

    Mapper
    Participant

    @johnpercy
    I checked the size of the db file on my phone and it is correct.
    fI I go to the LoPoints page (Menu > More functions > LoPoints) it is empty ands says ‘No data in list!’.
    What other ways are there to access LoPoints? I would like to be able to search in different categories of POI.

    #35347

    mbe57
    Participant

    https://drive.google.com/drive/folders/1t1CYpIhHGZXjNBqOFUPQKTTvddj7VVCv
    Try the LATEST Alpha for LM4. Menion just decoupled the POIs from the maps (still, the naming conventions apply, otherwise no POI DBs recognized!).
    I just tried and it worked like a charm.

    #35356
    JohnPercy
    JohnPercy
    Participant

    @mapper
    [EN] 1. It looks like LoPoints search is unstable if there is not at least one LoMaps map and database. It may get into an endless loop saying no data.
    2. LoPoints can be used in:
    – reverse geocoding (address look up) on long tap. This does not work with OAM databases
    – offline address search. This also does not work with OAM databases
    – “Show on map” LoPoints poi overlays. This works with OAM databases.
    – Search and display LoPoints. This also works with OAM databases, though it can get stuck in a loop without a functioning LoMaps map and database.
    [DE] 1. Es sieht so aus, als ob die LoPoints-Suche instabil ist, wenn nicht mindestens eine LoMaps-Karte und -Datenbank vorhanden ist. Es kann zu einer Endlosschleife kommen, in der keine Daten angezeigt werden.
    2. LoPoints können verwendet werden in:
    – Umgekehrte Geokodierung (Adressensuche) bei langem Tippen. Dies funktioniert nicht mit OAM-Datenbanken
    – Offline-Adressensuche. Dies funktioniert auch nicht mit OAM-Datenbanken
    – “Auf Karte anzeigen” LoPoints Poi-Overlays. Dies funktioniert mit OAM-Datenbanken.
    – LoPoints suchen und anzeigen. Dies funktioniert auch mit OAM-Datenbanken, obwohl es ohne eine funktionierende LoMaps-Karte und -Datenbank in einer Schleife hängen bleiben kann.

    1 user thanked author for this post.
    #35360

    mbe57
    Participant

    @John: I just double checked – took out (renamed folders and files) all Locus POI DBs, even all LoMaps, hence only OAM maps (checked in and POIs left: with LM4 Alpha it does work correctly. Tried a handful of POI DBs.
    The pain we suffered around OAM POIs in Pro and Free 3.x is no longer.
    One thing to keep in mind, though: if you select “Points around”, but your screen is not matching any POI content, then this message “No data in list!” shows up. Once you move the map to the area of the POI DB and do this search again, you get correct results.

    1 user thanked author for this post.
    #35362

    mbe57
    Participant

    @John: Ich habe gerade nochmal geprüft – alle Locus POI DBs, sogar alle LoMaps, herausgenommen (Ordner und Dateien umbenannt ), also nur noch OAM-Karten (gecheckt im Karten-Manager) und OAM-POIs übrig: mit LM4 Alpha funktioniert es korrekt. Versuchte eine Handvoll POI-DBs.
    Der Schmerz, den wir um OAM-POIs in Pro und Free 3.x erlitten haben, ist nicht mehr vorhanden.
    Eines sollten Sie jedoch bedenken: Wenn Sie “Points around” auswählen, aber der Kartenausschnitt nicht mit der POI-DB überlappt, dann erscheint die Meldung “Keine Daten in der Liste!” Wenn Sie die Karte in den Bereich der POI-DB verschieben und diese Suche erneut durchführen, erhalten Sie korrekte Ergebnisse.

    Übersetzt mit http://www.DeepL.com/Translator (kostenlose Version) und ein WENIG korrigiert :-)

    #35368

    Eichhorn
    Participant

    Hatte gestern mal diese Beta Version, welche mbe57 verlinkt hat probiert, da klappt alles auf Anhieb. Danach hatte ich alles was mit Locus zusammen hängt deinstalliert. Alle aufgezeichneten Tacks gelöscht, alle restlichen Ordner+Karten usw. gelöscht. Locus pro aus dem Playstore komplett neu installiert, alles neu eingerichtet (kein backup oder so), die POI´s und die Karten über die Schnellinstallation neu installiert und siehe da, es funktioniert alles wie es soll.
    Es ist eben “Technik die begeistert”. :-)
    Liebe Grüße und einen schönen 1. Mai!

Viewing 15 posts - 166 through 180 (of 262 total)

You must be logged in to reply to this topic.