Viewing 15 posts - 286 through 300 (of 331 total)
  • Author
    Posts
  • #45329
    Tobias
    Keymaster

    Bitte an Tobias:
    Bitte vergleiche doch mal deine .xml Dateien für die Locus-Schnell-Installation, z.B. die Installation der Themes alleine oder als Bestandteil einer Karte, z.B. der Alps, siehe Anhang.
    lg und xund bleim, Peter

    Aus welchem Grund, klappt etwas nicht und wenn ja wo?

    Developer of Elevate mapstyle

    #45331
    Peter47
    Participant

    Aus welchem Grund, klappt etwas nicht und wenn ja wo?

    Ich versuche das Problem von Freischneider zu klären.
    Da ich kein Locus habe um das nachvollziehen zu können hab ich einfach Mal recherchiert wie ihr das macht, und da sind mir Inkonsistenzen in den .xml-Dateien aufgefallen, ob das die Ursache sein könnte weiß ich nicht.
    Beispiel in Elevate.xml: <dest><![CDATA[/mapsVector/_themes/Elevate-icons.zip]]></dest>
    Beispiel in Alps.xml: <dest><![CDATA[/mapsVector/_themes/Elevate/Elevate-icons.zip]]></dest>
    Mir kommt das zumindest verdächtig vor, da die Locus Schnellinstallation des Winter-Fork offensichtlich nicht funktioniert hat.
    Ich hab das mittlerweile an die Alps-xml angepasst und warte auf weitere Tests……

    #45333
    ChristianK
    Moderator

    jetzt kommt doch die Winter-Saison

    Die Pisten sind in den Karten drin, es ändert sich bloss nichts
    ??

    #45335
    Peter47
    Participant

    Ist ja OK, ich hoffe aber immer noch daß irgendwann auch das Problem der Duplikate besonders bei den Langlaufloipen angegangen wird.
    Auch kein gravierendes Problem, da es mir ja gelungen ist, eine Umgehungslösung dafür zu implementieren.
    Als Beispiel: Bei möglichen Duplikaten wird der Track ausgeblendet und nur der Track-Name angezeigt, der meist beim Original fehlt. Das mit den Relationen ist halt eine wirre Angelegenheit.
    lg und xund bleim, Peter

    #45337
    Tobias
    Keymaster

    Aus welchem Grund, klappt etwas nicht und wenn ja wo?

    Ich versuche das Problem von Freischneider zu klären.
    Da ich kein Locus habe um das nachvollziehen zu können hab ich einfach Mal recherchiert wie ihr das macht, und da sind mir Inkonsistenzen in den .xml-Dateien aufgefallen, ob das die Ursache sein könnte weiß ich nicht.
    Beispiel in Elevate.xml: <dest><![CDATA[/mapsVector/_themes/Elevate-icons.zip]]></dest>
    Beispiel in Alps.xml: <dest><![CDATA[/mapsVector/_themes/Elevate/Elevate-icons.zip]]></dest>
    Mir kommt das zumindest verdächtig vor, da die Locus Schnellinstallation des Winter-Fork offensichtlich nicht funktioniert hat.
    Ich hab das mittlerweile an die Alps-xml angepasst und warte auf weitere Tests……

    Die sind unterschiedlich weil Christian sich die Dateien kopiert und nicht aufs selbe Verzeichnis zurückgreift. Funktionieren tun deshalb beide.
    Warum installierst du nicht Locus zum Testen, geht auch in der kostenlosen Version?
    Wie gesagt habe ich deine Schnellinstallation getestet und die geht. Freischneider hatte leider nicht klar geschrieben, ob er überhaupt deinen Fork installiert hat oder ob er in der normalen Elevate Wintersport erwartet:

    Ich habe mir gerade die neueste Elevate mit Locus schnellinstallation geholt. Aber da ist kein Winter Thema zum auswählen.

    Developer of Elevate mapstyle

    #45340
    Peter47
    Participant

    Immer noch ein Mißverständnis:
    Christian kann die nicht einfach nur kopiert haben, da diese unterschiedlich sind:
    In der <dest> fehlt bei Elevate.xml das Unterverzeichnis “/Elevate”.

    #45343
    Tobias
    Keymaster

    Immer noch ein Mißverständnis:
    Christian kann die nicht einfach nur kopiert haben, da diese unterschiedlich sind:
    In der <dest> fehlt bei Elevate.xml das Unterverzeichnis “/Elevate”.

    Er hat sich die Theme-Dateien kopiert und nicht die XMLs, die hat er gemacht, und die Pfade entsprechend gemacht, wie er die Theme-Dateien abgelegt hat. Es funktioniert dementsprechend und es gibt keine Beschwerden :-)

    Developer of Elevate mapstyle

    #45345
    Peter47
    Participant

    Bitte um Nachsicht wenn das dumme Fragen sind, aber ich will es halt verstehen:
    Meine Theorie ist, daß <source> das Verzeichnis ist, in dem wir eine Datei bereitstellen, dieses darf natürlich unterschiedlich sein, aber <dest> ist ein lokales Verzeichnis bei Locus, das muß doch identisch sein ???
    Wo liegt mein Denkfehler ???

    #45347
    Tobias
    Keymaster

    Leider sagst du wieder nicht, was nicht klappt.
    Ich kann nur für meine Schnellinstallation sprechen, da enthält Elevate-icons.zip u.a. den Unterordner Elevate, in dem dann die Dateien aus Elevate.zip extrahiert werden. Deshalb zuerst ohne den Ordner, dann mit (weil Locus immer Unterordner braucht, andere Apps nicht).
    Ob und wie Christian das macht, kann er dir sagen bzw. kannst du selber nachvollziehen.

    Developer of Elevate mapstyle

    #45349
    ChristianK
    Moderator

    Hier die Docu zum Locus interface:

    https://docs.locusmap.eu/doku.php?id=manual:advanced:customization:actions

    Hier ein Script für die Karten + Elevate

    <?xml version='1.0' encoding='UTF-8'?>
    <locusActions>
      <download>
        <source><![CDATA[http://download.openandromaps.org/mapsV5/europe/Azores.zip]]></source>
        <dest><![CDATA[/mapsVector/Azores.zip]]></dest>
       <after>extract|deleteSource|refreshMap</after>
      
    </download>
      <download>
         <source><![CDATA[http://download.openandromaps.org/themes/Elevate.zip]]></source>
         <dest><![CDATA[/mapsVector/_themes/Elevate/Elevate.zip]]></dest>
         <after>extract|deleteSource</after>
      </download>
      <download>
         <source><![CDATA[http://download.openandromaps.org/themes/Elevate_icons.zip]]></source>
         <dest><![CDATA[/mapsVector/_themes/Elevate/Elevate-icons.zip]]></dest>
         <after>extract|deleteSource</after>
      </download>
    </locusActions>
    
    1 user thanked author for this post.
    #45353
    Peter47
    Participant

    Winterfork kann nun auch per Schnell-Installation auf Locus geladen werden.
    Lediglich die Icons für die Themenauswahl werden noch nicht korrekt übernommen, das hat auf die Funktion aber keinerlei Einfluss.

    1 user thanked author for this post.
    #45355
    Tobias
    Keymaster

    Die Icons müssen einfach mit selben Namen wie die xml Dateien, nur png Endung, im gleichen Ordner liegen. Ich hab die nur in eine extra Datei ausgelagert (und auch die Legende), damit ich bei anderen Apps den Theme Ordner nicht mit unnötigen Dateien zumülle.

    Developer of Elevate mapstyle

    1 user thanked author for this post.
    #45357
    Peter47
    Participant

    Habs soeben versucht ….. und klappt.
    Hab wieder was dazugelernt …. und auch Locus zum Testen installiert.

    1 user thanked author for this post.
    #45366
    Peter47
    Participant

    Da es offensichtlich auch Mißverständnisse bezüglich des Ladens des Winter-Themes gegeben hat habe ich die Webseite mit der Anleitung nachgebessert:
    https://www.senotto.de/Tipps_Tricks/GPS/OAM_Winter/OAM_Winter.html
    Ich hoffe daß jetzt jede Klarheit restlos beseitigt ist :-)
    lg und xund bleim, Peter

    #45385
    freischneider
    Participant

    Ich glaube ich habe das nicht richtig verstanden. So wie ich das jetzt verstehe reicht es nicht aus nur Elevate zu installieren. Ich muss anscheinend noch für die Winterdarstellung was zusätzliches installieren ?
    Ist das die Aufgabe die noch offen ist. Und im Final ist dann alles im Elevate enthalten ?

Viewing 15 posts - 286 through 300 (of 331 total)
  • You must be logged in to reply to this topic.